Latency / Timeout viewing appointments in platform from Demographics
Incident Report for Kareo
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 29, 2018 - 14:29 PDT
Investigating
We’ve received reports of latency / timeout viewing appointments in platform from Demographics and printing patients from platform.
Our Engineering team is aware of the issue and working on a resolution.
Posted 9 months ago. Oct 29, 2018 - 09:10 PDT
This incident affected: Kareo Clinical (EHR).