Credit Card payments taken from Platform
Incident Report for Kareo
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 21, 2018 - 11:13 PDT
Investigating
We received notification where users are unable to finalize credit card payments from platform application.
We are currently researching this issue.

We will provide updates as soon as possible.

Thank you,

Kareo Support
Posted 10 months ago. Sep 21, 2018 - 08:51 PDT
This incident affected: Kareo Clinical (EHR).