Maintenance - Tuesday 3/19/19 4 - 5 PM PST
Incident Report for Kareo
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 20, 2019 - 08:31 PDT
Investigating
The Kareo Engineering team will be completing routine maintenance today Tuesday 3/19 from 4 - 5 PM PST.

During this time clients may be unable to complete the Practice Setup Wizard in the Desktop Application or app.kareo.com. We recommend delaying in practice setup until after the maintenance window is completed.

We apologize for any inconvenience this may cause.
Posted 4 months ago. Mar 19, 2019 - 15:17 PDT
This incident affected: Kareo Clinical (EHR), Kareo Billing (PM, RCM), and Partner EHR.