Duplicate ERA's received.
Incident Report for Kareo
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 01, 2018 - 10:50 PDT
Update
Trizetto has identified the issue and implemented a solution to ensure future incidents will not occur - we apologize for any inconvenience this may have caused.
Note: Transactional clients will not be charged for any duplicate remittances received
Posted 9 months ago. Nov 01, 2018 - 10:50 PDT
Identified
We are currently investigating an issue with the clearinghouse which is causing duplicate ERA's to reflect in the account.

Thank you for your patience,
Kareo Support.
Posted 9 months ago. Oct 16, 2018 - 09:11 PDT
This incident affected: Kareo Billing (PM, RCM).