Clearinghouse Closures - Thanksgiving Holiday
Incident Report for Kareo
Resolved
This incident has been resolved.
Posted Dec 19, 2018 - 09:33 PST
Monitoring
Trizetto:
In observance of the Thanksgiving holiday, TriZetto Provider Solutions will be closed on Thursday, November 22, 2018, and Friday November 23, 2018.

Claims submitted after 2 p.m. CST on Wednesday, November 21, 2018 will be sent to the payers on Monday, November 26, 2018 during our regular processing.

Jopari:
Jopari's corporate offices will be closed on Thursday, November 22 and Friday, November 23, 2018 in observance of the Thanksgiving Holiday.

Jopari's Processing Center will accept file uploads and transmissions throughout the Holiday period. Rectification of file errors received over the Holiday will be promptly attended to commencing Monday morning, November 26, 2018.

Print & Mail, Payment Processing, outbound Clearing House and Payer transmissions will also resume as normally scheduled on Monday morning, November 26, 2018.
Posted Nov 21, 2018 - 11:05 PST
This incident affected: Kareo Billing (PM, RCM) and Partner EHR.